The plan is to install VIOS straight to a SAN LUN, and NOT to a local disk drive.
- Download the VIOS Install ISO’s and burn them to a DVD-R (Required to be associated to your IBM Account + hardware)
- Have LUNS carved up and presented to the target system
- Place VIOS Install DVD 1 in the media tray, and in Advanced Management Module (AMM) associate Media Tray to Blade 1.
- Use Remote Control (or cli) to take control of target blade (at slot 1), reboot it.
- Go into SMS menus’ and boot it from USB CDROM
- Start installation (Change disk to install to the target LUN).
- After VIOS is installed it will automatically reboot. Go into SMS and install that drive as default.
Upon reboot, you should login to the system, a password change (forced) will happen and then type
license -accept
.$ ioslevel
2.1.3.0 fp10-23
VIOS Configuration
Active Ethernet Adapter Testing
In a normal build, one would want to assign an IP to one of these ethernet adapters at a time (using the Host Ethernet Adapters (HEA’s)) and then do a ping test to the gateway IP, and to an address on a different VLAN. Once the adapters work properly, bring down the ethernet interface(s), and rmdev them so you will lose the configuration and then scan the bus again.ifconfig enX down ifconfig enX detach rmdev -dl entX rmdev -dl enX rmdev -dl etX cfgmgr -v
lsdev |grep ent
ent0 Available Logical Host Ethernet Port (lp-hea)
ent1 Available Logical Host Ethernet Port (lp-hea)
ent2 Available Gigabit Ethernet-SX PCI-X Adapter (xxx703)
ent3 Available Gigabit Ethernet-SX PCI-X Adapter (xxx703)
ent4 Available Gigabit Ethernet-SX PCI-X Adapter (xxx703)
ent5 Available Gigabit Ethernet-SX PCI-X Adapter (xxx703)
ent6 Available Virtual I/O Ethernet Adapter (l-lan)
ent7 Available Virtual I/O Ethernet Adapter (l-lan)
ent8 Available Virtual I/O Ethernet Adapter (l-lan)
ent9 Available Virtual I/O Ethernet Adapter (l-lan)
ibmvmc0 Available Virtual Management Channel
mkvdev -lnagg ent0 -attr backup_adapter=ent1 netaddr=192.168.1.1 ## To the two adapters found to work during your test earlier.
Set Card to Promiscuous Mode
In order to create a SEA, you need virtual network devices. These are normal generated automatically, however, with newer VIOS install they weren’t. If needed runmkgencfg -o init
to have them automatically generated.Once the Virtual Ethernet devices are created, you can create a SEA. Using the newly created Etherchannel adapter + 1 virtual adapter. Adapter has to be in promiscuous mode to accomplish this.
chhwres -r hea -o s -l 23000000 -g 1 -a promisc_lpar_id=1 --physport 0 chhwres -r hea -o s -l 23000000 -g 1 -a promisc_lpar_id=1 --physport 1
The above command will work with the first interface card. If you have another card, the hardware_ID will be different. To determine what the HW ID’s are, run the command
lshwres -r hea --rsubtype phys --level port
. Now that the ports are in promiscuous mode, you can safely create the SEA.
SEA
mkvdev -sea ent10 -vadapter ent8 -default ent8 -defaultid 1
Create Virtual Media Library
Login to the system as the regular user. Typelsrep
from
the cli. If the repository hasn’t been created, you need to create it.
Issue the following command to create a repository of 20GB. NOTE: The
repository is required to be part of rootvg.mkrep -sp rootvg -size 20G